Skip to main content

Security tracker

CVE-2026-42208: BerriAI LiteLLM SQL Injection Vulnerability

In short

BerriAI LiteLLM has a weakness classified as SQL injection (CWE-89). CISA added it to its Known Exploited Vulnerabilities catalog on 2026-05-08. NVD lists CVSS 4.0 at 9.3 CRITICAL.

What it is

“BerriAI LiteLLM contains a SQL injection vulnerability that allows an attacker to read data from the proxy's database and potentially modify it, leading to unauthorized access to the proxy and the credentials it manages.” — CISA KEV, retrieved 2026-11-01
“LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.” — NVD, retrieved 2026-11-01

Who is affected

BerriAI LiteLLM. NVD lists the following versions as affected:

  • Versions from 1.81.16 inclusive, before 1.83.7

Exploitation status

CISA KEV added: 2026-05-08. Known ransomware campaign use: Not reported by CISA. Due date CISA set for US federal civilian agencies: 2026-05-11.

Scores

NVD CVSS 4.0: 9.3 CRITICAL; vector CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X; source [email protected].

EPSS by FIRST: 89.42%; percentile 99.78; score date 2026-10-31. EPSS estimates the probability of exploitation in the next 30 days.

CWE: CWE-89.

Timeline

Source events
DateEvent
2026-05-08CISA KEV added
2026-05-08T04:16:19.923NVD published
2026-05-11CISA KEV due
2026-10-26T20:10:00.160NVD last modified
2026-10-31FIRST EPSS score

CISA required action

“Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.” — CISA KEV

What to do

  • Confirm whether you run BerriAI LiteLLM and which version.
  • Apply the vendor update or mitigation in the advisory.
  • Follow CISA’s required action.
  • Review the vendor guidance on signs of compromise.
  • Track the fix through completion.

Sources and dates

CISA Known Exploited Vulnerabilities Catalog, version 2026.10.30; retrieved 2026-11-01. CISA KEV data: CC0 1.0. No endorsement by CISA.

NVD retrieved: 2026-11-01. This product uses the NVD API but is not endorsed or certified by the NVD.

EPSS scores by FIRST; score date 2026-10-31.

Check your own domain's public security settings

The snapshot checks a domain you own or are authorized to check for DNS, HTTPS/TLS and web-header hygiene. It does not test for this CVE.