Skip to main content

Security tracker

CVE-2025-54068: Laravel Livewire Code Injection Vulnerability

In short

Laravel Livewire has a weakness classified as code injection (CWE-94). CISA added it to its Known Exploited Vulnerabilities catalog on 2026-03-20. NVD lists CVSS 4.0 at 9.2 CRITICAL.

What it is

“Laravel Livewire contain a code injection vulnerability that could allow unauthenticated attackers to achieve remote command execution in specific scenarios.” — CISA KEV, retrieved 2026-11-01
“Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.” — NVD, retrieved 2026-11-01

Who is affected

Laravel Livewire. NVD lists the following versions as affected:

  • Versions from 3.0.0 inclusive, before 3.6.4

Exploitation status

CISA KEV added: 2026-03-20. Known ransomware campaign use: Not reported by CISA. Due date CISA set for US federal civilian agencies: 2026-04-03.

Scores

NVD CVSS 4.0: 9.2 CRITICAL; vector CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X; source [email protected].

EPSS by FIRST: 96.28%; percentile 99.88; score date 2026-10-31. EPSS estimates the probability of exploitation in the next 30 days.

CWE: CWE-94.

Timeline

Source events
DateEvent
2025-07-17T19:15:25.470NVD published
2026-03-20CISA KEV added
2026-04-03CISA KEV due
2026-06-17T09:39:21.790NVD last modified
2026-10-31FIRST EPSS score

CISA required action

“Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.” — CISA KEV

What to do

  • Confirm whether you run Laravel Livewire and which version.
  • Apply the vendor update or mitigation in the advisory.
  • Follow CISA’s required action.
  • Review the vendor guidance on signs of compromise.
  • Track the fix through completion.

Sources and dates

CISA Known Exploited Vulnerabilities Catalog, version 2026.10.30; retrieved 2026-11-01. CISA KEV data: CC0 1.0. No endorsement by CISA.

NVD retrieved: 2026-11-01. This product uses the NVD API but is not endorsed or certified by the NVD.

EPSS scores by FIRST; score date 2026-10-31.

Check your own domain's public security settings

The snapshot checks a domain you own or are authorized to check for DNS, HTTPS/TLS and web-header hygiene. It does not test for this CVE.